ГлавнаяФорумДневникиФотоальбомы

Войти через:
Впервые на Nokia Club? Зарегистрируйтесь или воспользуйтесь формой логина. Телефоны Игры Темы Программы

 

Старые приложения могут работать плохо в Android P

Обсудить новость+5 Интересно! Добавлено — 19.03.2018

В очередном превью Android P для разработчиков обнаружена функция, проверяющая версию API, с помощью которого написаны приложения для мобильных устройств. Минимальная указанная версия — 17, что соответствует Android 4.2 Jelly Bean. Если приложение написано на более раннем API, всплывающее предупреждение сообщит о возможных проблемах в работе ПО.

Так Google пытается заставить разработчиков использовать более актуальные версии API и гарантировать пользователям их поддержку в современных смартфонах. Впрочем, с учетом темпов распространения новых версий Android, такой подход эффективен лишь отчасти.

По данным Google за февраль, наиболее актуальная версия — Android 8 Oreo — установлена на 1,1% мобильных устройств, Nougat — на 28,5%, Marshmallow — 28,1%.




Norden19.03.18 18:12 #
Цитата:
В очередном превью Android P для разработчиков обнаружена функция, проверяющая версию API, с помощью которого написаны приложения для мобильных устройств. Минимальная указанная версия — 17, что соответствует Android 4.2 Jelly Bean. Если приложение написано на более раннем API, всплывающее предупреждение сообщит о возможных проблемах в работе ...
https://allnokia.ru/news/304728/
А с учётом того, что многие производители не особо заботятся об обновлении ПО своих продуктов до последней версии Android, то всё выглядит очень печально.ОбратитьсяЦитировать выделенное
ALEX199519.03.18 18:27 #
Googlе как-то мягко отностся к разработчикам. Давно пора отказаться от поддержки всего что ниже 6.0, и вести более жесткую политику обновлений устройств. П.С. Сам имею 4.2.2, но суть в том, что необходимо двигаться вперед, а не тормозиться об старые API.ОбратитьсяЦитировать выделенное
Norden19.03.18 18:35 #
ALEX1995 пишет:
Googlе как-то мягко отностся к разработчикам. Давно пора отказаться от поддержки всего что ниже 6.0, и вести более жесткую политику обновлений устройств. П.С. Сам имею 4.2.2, но суть в том, что необходимо двигаться вперед, а не тормозиться об старые API.

Я думаю, проблема не в разработчиках, они пишут программы под более распространённое ПО. Со стороны Google имеет смысл требовать от производителей своевременного обновления ПО своих продуктов. Естественно, если железо позволяет.ОбратитьсяЦитировать выделенное
nessin21.03.18 04:27 #
ALEX1995, тоесть превращать в звонилки еще нормально работающие и некогда не дешевые устройстваОбратитьсяЦитировать выделенное
ALEX199521.03.18 10:33 #
nessin, я говорю о слишком недалекоглядной политике гугла. Разработчики видят API16, API17, API18, API19, API20, API21, API22, API23 (это kitkat, marshmallowm nougat и т.д.) и как вы думаете, под что они будут разрабатывать? Под самую новую АПИшку. Через год выйдет новая АПИ и разработчиками придется переписывать свое приложение под новый API. ИМ не захочется этого делать а обратная совместимость у APIшек новых очень плохая. Я думаю Вы улавливаете мою мысль.ОбратитьсяЦитировать выделенное









  • Тренды
  • Статьи
  • Личный опыт

TOP-модели
1 Nokia 3.1 Plus
2 Nokia 2.1
3 Nokia 8.1
Рассылка  Настройки





Другие мобильные клубы
Samsung клубSony Ericsson клубSiemens клуб